I have just heard back from my hosting company and they have provided this report. They suggest that if these connections are not being made by me that there may be a malicious software or something running. However we did all this cleanup last week and I thought all that was resolved.
From Hostgator.com
Hello, Bryce.
First, let me assure you that my appreciation is genuine. You've attempted to load other sites on the same Shared server; I thought this to be remarkable.
Here is what I'm seeing on the server (the last 10 entries from the search):
root@gt2 [~]# grep 122.58.142.139 /var/log/messages | tail
Sep 5 19:22:24 gt2 kernel: APACHE-FLOOD : IN=eth0 OUT= MAC=00:1e:c9:44:65:c5:00:1a:a1:82:26:3f:08:00 SRC=[removed] DST=[removed] LEN=52 TOS=0x00 PREC=0x00 TTL=241 ID=27535 DF PROTO=TCP SPT=53804 DPT=80 WINDOW=4380 RES=0x00 SYN URGP=0
Sep 5 19:22:27 gt2 kernel: APACHE-FLOOD : IN=eth0 OUT= MAC=00:1e:c9:44:65:c5:00:1a:a1:82:26:3f:08:00 SRC=[removed] DST=[removed] LEN=48 TOS=0x00 PREC=0x00 TTL=241 ID=6383 DF PROTO=TCP SPT=53804 DPT=80 WINDOW=4380 RES=0x00 SYN URGP=0
Sep 5 19:22:39 gt2 kernel: APACHE-FLOOD : IN=eth0 OUT= MAC=00:1e:c9:44:65:c5:00:1a:a1:82:26:3f:08:00 SRC=[removed] DST=[removed] LEN=52 TOS=0x00 PREC=0x00 TTL=241 ID=49792 DF PROTO=TCP SPT=53762 DPT=80 WINDOW=4380 RES=0x00 SYN URGP=0
Sep 5 19:22:40 gt2 kernel: APACHE-FLOOD : IN=eth0 OUT= MAC=00:1e:c9:44:65:c5:00:1a:a1:82:26:3f:08:00 SRC=[removed] DST=[removed] LEN=52 TOS=0x00 PREC=0x00 TTL=241 ID=61226 DF PROTO=TCP SPT=53786 DPT=80 WINDOW=4380 RES=0x00 SYN URGP=0
Sep 5 19:22:44 gt2 kernel: APACHE-FLOOD : IN=eth0 OUT= MAC=00:1e:c9:44:65:c5:00:1a:a1:82:26:3f:08:00 SRC=[removed] DST=[removed] LEN=52 TOS=0x00 PREC=0x00 TTL=241 ID=3506 DF PROTO=TCP SPT=53749 DPT=80 WINDOW=4380 RES=0x00 SYN URGP=0
Sep 5 19:22:51 gt2 kernel: APACHE-FLOOD : IN=eth0 OUT= MAC=00:1e:c9:44:65:c5:00:1a:a1:82:26:3f:08:00 SRC=[removed] DST=[removed] LEN=52 TOS=0x00 PREC=0x00 TTL=241 ID=50125 DF PROTO=TCP SPT=53754 DPT=80 WINDOW=4380 RES=0x00 SYN URGP=0
Sep 5 19:23:49 gt2 kernel: APACHE-FLOOD : IN=eth0 OUT= MAC=00:1e:c9:44:65:c5:00:1a:a1:82:26:3f:08:00 SRC=[removed] DST=[removed] LEN=52 TOS=0x00 PREC=0x00 TTL=241 ID=11739 DF PROTO=TCP SPT=53834 DPT=80 WINDOW=4380 RES=0x00 SYN URGP=0
Sep 5 19:23:51 gt2 kernel: APACHE-FLOOD : IN=eth0 OUT= MAC=00:1e:c9:44:65:c5:00:1a:a1:82:26:3f:08:00 SRC=[removed] DST=[removed] LEN=52 TOS=0x00 PREC=0x00 TTL=241 ID=13501 DF PROTO=TCP SPT=53834 DPT=80 WINDOW=4380 RES=0x00 SYN URGP=0
Sep 5 19:23:52 gt2 kernel: APACHE-FLOOD : IN=eth0 OUT= MAC=00:1e:c9:44:65:c5:00:1a:a1:82:26:3f:08:00 SRC=[removed] DST=[removed] LEN=52 TOS=0x00 PREC=0x00 TTL=241 ID=21982 DF PROTO=TCP SPT=53834 DPT=80 WINDOW=4380 RES=0x00 SYN URGP=0
Sep 5 19:23:53 gt2 kernel: APACHE-FLOOD : IN=eth0 OUT= MAC=00:1e:c9:44:65:c5:00:1a:a1:82:26:3f:08:00 SRC=[removed] DST=[removed] LEN=48 TOS=0x00 PREC=0x00 TTL=241 ID=31329 DF PROTO=TCP SPT=53834 DPT=80 WINDOW=4380 RES=0x00 SYN URGP=0
Note your IP address in the "SRC" field. The threshold is 20 new, invalid, or "untracked" connections within a 5 second period. Normal usage, such as making a change and then refreshing the website in a browser, will not trigger this rule.
The following excerpts are from the Apache error log. Note the timestamps at the beginning of each entry:
root@gt2 [/usr/local/apache/logs]# grep 122.58.142.139 error_log
[Sun Sep 05 18:45:38 2010] [error] [client 122.58.142.139] File does not exist: /home/editnew/public_html/favicon.ico
[Sun Sep 05 18:45:38 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:45:43 2010] [error] [client 122.58.142.139] File does not exist: /home/thedigi/public_html/favicon.ico
[Sun Sep 05 18:45:43 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:45:54 2010] [error] [client 122.58.142.139] File does not exist: /home/thedigi/public_html/favicon.ico
[Sun Sep 05 18:45:54 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:45:59 2010] [error] [client 122.58.142.139] File does not exist: /home/thedigi/public_html/favicon.ico
[Sun Sep 05 18:45:59 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:46:36 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:46:36 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:46:45 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:46:45 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:46:59 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:46:59 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:05 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:05 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:07 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:07 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:11 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:11 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:14 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:14 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:16 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:16 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:18 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:18 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:21 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:21 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:36 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:36 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:38 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:38 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:48 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:48 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:49 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:49 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:51 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:51 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:52 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:52 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:53 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:53 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:55 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:55 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:47:58 2010] [error] [client 122.58.142.139] File does not exist: /home/elm1505/public_html/favicon.ico
[Sun Sep 05 18:47:58 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:48:17 2010] [error] [client 122.58.142.139] File does not exist: /home/global26/public_html/favicon.ico
[Sun Sep 05 18:48:17 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:48:26 2010] [error] [client 122.58.142.139] File does not exist: /home/global26/public_html/favicon.ico
[Sun Sep 05 18:48:26 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:48:42 2010] [error] [client 122.58.142.139] File does not exist: /home/global26/public_html/favicon.ico
[Sun Sep 05 18:48:42 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:49:14 2010] [error] [client 122.58.142.139] File does not exist: /home/global26/public_html/favicon.ico
[Sun Sep 05 18:49:14 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:49:37 2010] [error] [client 122.58.142.139] File does not exist: /home/global26/public_html/favicon.ico
[Sun Sep 05 18:49:37 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:55:23 2010] [error] [client 122.58.142.139] File does not exist: /home/global26/public_html/favicon.ico
[Sun Sep 05 18:55:23 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:55:29 2010] [error] [client 122.58.142.139] File does not exist: /home/global26/public_html/favicon.ico
[Sun Sep 05 18:55:29 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:56:04 2010] [error] [client 122.58.142.139] File does not exist: /home/global26/public_html/favicon.ico
[Sun Sep 05 18:56:04 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 18:57:37 2010] [error] [client 122.58.142.139] File does not exist: /home/global26/public_html/favicon.ico
[Sun Sep 05 18:57:37 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:14:17 2010] [error] [client 122.58.142.139] File does not exist: /home/pozitif/public_html/favicon.ico
[Sun Sep 05 19:14:17 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:14:23 2010] [error] [client 122.58.142.139] File does not exist: /home/pozitif/public_html/favicon.ico
[Sun Sep 05 19:14:23 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:14:28 2010] [error] [client 122.58.142.139] File does not exist: /home/pozitif/public_html/favicon.ico
[Sun Sep 05 19:14:28 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:14:30 2010] [error] [client 122.58.142.139] File does not exist: /home/pozitif/public_html/favicon.ico
[Sun Sep 05 19:14:30 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:14:32 2010] [error] [client 122.58.142.139] File does not exist: /home/pozitif/public_html/favicon.ico
[Sun Sep 05 19:14:32 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:14:37 2010] [crit] [client 122.58.142.139] (13)Permission denied: /home/publiemp/public_html/publiempleat/PUBLIEMPLEAT/history/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer:
http://www.publiempleat.com/publiempleat/P…BLIEMPLEAT.html
[Sun Sep 05 19:14:37 2010] [crit] [client 122.58.142.139] (13)Permission denied: /home/publiemp/public_html/publiempleat/PUBLIEMPLEAT/history/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer:
http://www.publiempleat.com/publiempleat/P…BLIEMPLEAT.html
[Sun Sep 05 19:14:38 2010] [error] [client 122.58.142.139] File does not exist: /home/publiemp/public_html/favicon.ico
[Sun Sep 05 19:14:38 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:14:59 2010] [crit] [client 122.58.142.139] (13)Permission denied: /home/publiemp/public_html/publiempleat/PUBLIEMPLEAT/history/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer:
http://www.publiempleat.com/publiempleat/P…BLIEMPLEAT.html
[Sun Sep 05 19:14:59 2010] [crit] [client 122.58.142.139] (13)Permission denied: /home/publiemp/public_html/publiempleat/PUBLIEMPLEAT/history/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer:
http://www.publiempleat.com/publiempleat/P…BLIEMPLEAT.html
[Sun Sep 05 19:15:00 2010] [error] [client 122.58.142.139] File does not exist: /home/publiemp/public_html/favicon.ico
[Sun Sep 05 19:15:00 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:17:12 2010] [error] [client 122.58.142.139] File does not exist: /home/love/public_html/favicon.ico
[Sun Sep 05 19:17:12 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:19:54 2010] [error] [client 122.58.142.139] File does not exist: /home/love/public_html/favicon.ico
[Sun Sep 05 19:19:54 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:21:32 2010] [error] [client 122.58.142.139] ModSecurity: Access denied with code 403 (phase 2). Match of "rx (/wp-content/plugins/one-click-plugin-updater)|(www/delivery/ajs.php)|(www/admin/dashboard.php)|(/wp-content/(themes|uploads)(?:/(\\\\w+))*/(tim)?thumb.php|/pl/download\\\\?file=http|/index\\\\.php/admin/system_config/save/section/payment/|^/b/ss/mxmacromedi …" against "REQUEST_FILENAME" required. [file "/opt/mod_security/hg_rules.conf"] [line "69"] [id "1234234"] [msg "JITP:1234234"] [hostname "www.ezytrak.com"] [uri "/cgi-bin/tsource/refer.cgi"] [unique_id "TIQ0DEo221IAACj6@NMAAACX"]
[Sun Sep 05 19:21:32 2010] [error] [client 122.58.142.139] File does not exist: /home/wwwezyt/public_html/403.shtml, referer:
http://ezytrak.com/
[Sun Sep 05 19:21:35 2010] [error] [client 122.58.142.139] File does not exist: /home/wwwezyt/public_html/favicon.ico
[Sun Sep 05 19:21:35 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:21:45 2010] [error] [client 122.58.142.139] ModSecurity: Access denied with code 403 (phase 2). Match of "rx (/wp-content/plugins/one-click-plugin-updater)|(www/delivery/ajs.php)|(www/admin/dashboard.php)|(/wp-content/(themes|uploads)(?:/(\\\\w+))*/(tim)?thumb.php|/pl/download\\\\?file=http|/index\\\\.php/admin/system_config/save/section/payment/|^/b/ss/mxmacromedi …" against "REQUEST_FILENAME" required. [file "/opt/mod_security/hg_rules.conf"] [line "69"] [id "1234234"] [msg "JITP:1234234"] [hostname "www.ezytrak.com"] [uri "/cgi-bin/tsource/refer.cgi"] [unique_id "TIQ0GUo221IAAAV-VegAAAAL"]
[Sun Sep 05 19:21:46 2010] [error] [client 122.58.142.139] File does not exist: /home/wwwezyt/public_html/403.shtml, referer:
http://ezytrak.com/
[Sun Sep 05 19:21:52 2010] [error] [client 122.58.142.139] File does not exist: /home/wwwezyt/public_html/favicon.ico
[Sun Sep 05 19:21:52 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:22:10 2010] [error] [client 122.58.142.139] File does not exist: /home/wwwezyt/public_html/favicon.ico
[Sun Sep 05 19:22:10 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:22:28 2010] [error] [client 122.58.142.139] File does not exist: /home/wwwezyt/public_html/favicon.ico
[Sun Sep 05 19:22:28 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:22:36 2010] [error] [client 122.58.142.139] File does not exist: /home/wwwezyt/public_html/favicon.ico
[Sun Sep 05 19:22:36 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:22:54 2010] [error] [client 122.58.142.139] File does not exist: /home/wwwezyt/public_html/favicon.ico
[Sun Sep 05 19:22:54 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
[Sun Sep 05 19:23:56 2010] [error] [client 122.58.142.139] File does not exist: /home/wwwezyt/public_html/favicon.ico
[Sun Sep 05 19:23:56 2010] [error] [client 122.58.142.139] script not found or unable to stat: /usr/local/cpanel/cgi-sys/404.html
It's possible that you are not initiating these connections, but they appear to be coming from your IP address. Given the number and frequency of the connections hitting the server, it's possible that your system is infected with malicious software. Please don't misunderstand my reason for stating this; I'm simply trying to troubleshoot the issue as it is presented.
Thanks
Bryce