Jump to content

Build Theme!
  •  
  • Infected?

WE'RE SURE THAT YOU'LL LOVE US!

Hey there! :wub: Looks like you're enjoying the discussion, but you're not signed up for an account. When you create an account, we remember exactly what you've read, so you always come right back where you left off. You also get notifications, here and via email, whenever new posts are made. You can like posts to share the love. :D Join 91675 other members! Anybody can ask, anybody can answer. Consistently helpful members may be invited to become staff. Here's how it works. Virus cleanup? Start here -> Malware Removal Forum.

Try What the Tech -- It's free!


Virus Was Cleared, But Windows Is Not Happy!


  • Please log in to reply
1 reply to this topic

#1 Guest_raptor_*

Guest_raptor_*
  • Guests

Posted 11 December 2004 - 12:21 PM

Hi all, The great Daemon helped me clear my trojan of my system, and this problem might not be related I've posted the below on other tech forums, no one yet has come up with a sensible solution (I dont want to format and install windows, it gives me the heebee jeebies just thinking about it) So I thought I would rack your brains with this. I've also done something daft, and that is uninstalling directx 8.1, I thought if it was gone then I would have been able to install directx 9, alas it would not install Im really quite stuck at the moment, so any advice would be great I dont think its got anything to do with my display adapter driver. In add/remove programs SP2 was sitting there quite the thing, system information however states the in use service pack is 1, I dont get that!! Here is what I posted yesterday: Would be grateful for any help for the following problem I have with my system: My system is only a couple of months old but I seem to be having problems with the display driver and updating direct x. Direct X is 8.1 (I find it hard to believe I bought it like this) Graphics card is ati radeon x600, the driver for this is ati2davg.dll, according to dxdiag The properties for the graphics card say this dll file is Not Digitally Signed (I've tried to update driver, but any install i try, always fails to install) In fact ran a little tool and it turns out none of my drivers are digitally signed So I reduced the security settings (to allow all active x controls) and changed the settings to allow unsigned drivers I've also tried to install automatic updates, it tries to download the critical updates but fails to install them The main message I am seeing from the directx 9 install is 'The software you are installing has not passed windows logo testing to verify its compatibility with windows XP, and a link on the dialog box to say why TESTING is so important, winlogo or something I think I dont have the greatest technical mind, so I feel stuck, it seems almost like a catch 22 situation. Cant update direct x because of the driver and i cant update the driver because of direct x, neither updates will install I've lost a lot of hair (not much left now) over the past few days, so any help would appreciated Any more info needed please shout P.S. tried system restore a couple of times, but right at the end it says it cannot restore

    Advertisements

Register to Remove


#2 Guest_raptor_*

Guest_raptor_*
  • Guests

Posted 14 December 2004 - 03:06 PM

A few days later, I'm now sorted, I'm gonna post the resolution to my problem for reference only. i bought my PC like this so just goes to show, they are not what they seem Issue: Windows components will NOT install For reference purposes System status: XP service pack 1, directx8.1, all drivers unsigned. (Service pack 2 is on the computer, however it is not active) Since I got the computer some critical updates would not install successfully, kept on trying though. Tried to install directx9, install failed, windows reported that it could not verify the software Tried to update graphics card driver, again windows failed to install reporting that it failed to install unsigned software (Sys info. reports every one of my drivers is unsigned) Went into safe mode and deleted directx 8.1 in the hope that this would enable directx9.c to install, booted up, dx9 would not install, system has no directx now Windows update tries and fails to install service pack 2, Manually tried to install critical updates, 3 out of 11 installed, then tried SP2 again, but no joy here. By now I’m scratching my head, what the hell is going on!! Tried posting on a few tech sites, every piece of advice was pointing to format hard drive and re-install of windows (Nooooooooo!!!!) I have previously tried to use the recovery disk, but this has never worked on my machine, decided to give it a go anyway. Set the restore point to the day after I bought my PC, this took about 20 minutes to complete and as it restarted, everything was looking fine until it finished booting up, the message that came up was ‘system restore has failed to restore to xx/xx/xxxx blah blah’ Ready to throw the machine out the window now, I gave directx 9.c another go at installing. Miracle upon miracles it installed. I opened up dxdiag to have a look at the details, dxdiag then went on the net and changed all my drivers from unsigned to signed (didn’t know it could that!!) Feeling loads better now, just got to get SP2 now As I was browsing I seen in Add/Remove programs that SP2 was sitting there quite the thing (why didn’t it install originally??) decided to remove it anyway. The screen visibly shook (or was that my frayed nerves) and a message popup says that the program was very unstable and I should reboot after uninstall. After successful uninstall tried yet again to install SP2, guess what no joy. New message returned now. Could not locate (some strange file name here). Please ensure ‘Cryptographic Services’ is running. That totally threw me; I tried a search engine with my new strange message. Not a lot returned, mainly forum stuff based on the Microsoft knowledge base, and a lot of really technical fixes for catalogue database problems. After trawling through all this, I found one specific to me The cryptographic service needed rebuilding, at the command prompt I keyed in del /q "%SystemRoot%\System32\Catroot2\Edb.log (wasn’t exactly this line but very similar) and hit enter. That was it, installed SP2 now. Success!!!!!!!! So my problem was down too a Windows catalogue database error (Mr Gates, if I ever saw you I’d kick your rear man!!!

Related Topics



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users