Jump to content

Build Theme!
  •  
  • Infected?

WE'RE SURE THAT YOU'LL LOVE US!

Hey there! :wub: Looks like you're enjoying the discussion, but you're not signed up for an account. When you create an account, we remember exactly what you've read, so you always come right back where you left off. You also get notifications, here and via email, whenever new posts are made. You can like posts to share the love. :D Join 91701 other members! Anybody can ask, anybody can answer. Consistently helpful members may be invited to become staff. Here's how it works. Virus cleanup? Start here -> Malware Removal Forum.

Try What the Tech -- It's free!


Photo

Google.com opens in German


  • Please log in to reply
24 replies to this topic

#1 Desert rider

Desert rider

    Authentic Member

  • Authentic Member
  • PipPip
  • 46 posts

Posted 10 February 2008 - 03:09 PM

I've got a problem with all my browsers (IE 7, Firefox 2 and Opera 9) where Google.com default page has a link on it to Google Deutschland. If I clear the cache and cookies on all browsers and reopen the Google.com link it will open on the Google Germany page. There is a link there for Google in English and when I select that Google opens in English but with the Google Deutschland link. Yahoo.com just has a link on it for Y Germany.

I have worked with LD Tate on the Spyware / Malware / Virus Removal/HiJack This forum and we have pretty much exhausted his ideas. No apparent malware of any kind on my system. Click here to see a history of what we did to try and eliminate the problem.

System performs fine with no hangs or other problems and general performance is normal.
Platform: Windows XP SP2

TIA for any help.

Edited by Desert rider, 11 February 2008 - 04:37 PM.

    Advertisements

Register to Remove


#2 Abydos

Abydos

    WTT Tech Emeritus

  • Authentic Member
  • PipPipPipPipPip
  • 1,736 posts

Posted 10 February 2008 - 06:05 PM

Hi Desert Rider Have you checked the language preferences in your browser's? "Google makes use of the Web's standard language-preferences mechanism, the HTTP accept-language header, to determine the display language. Browsers can have multiple accept-languages, arranged in order of user preference." --from Google Faq page. In IE it should be located in Internet options-->Tools / Language option In Firefox it should be located in Settings-->Advanced-->Languages / Radio button to switch or add additional language to show webpages in. In Opera I can't tell. Never used the browser. Regards Abydos

Abydos

Asking for Technical Help


Preventing Malware Slow PC? Recovery Console!

"I am not young enough to know everything" - Oscar Wilde


#3 Desert rider

Desert rider

    Authentic Member

  • Authentic Member
  • PipPip
  • 46 posts

Posted 10 February 2008 - 06:53 PM

Thanks for the reply Abydos. One of the first things I looked for was the Language option in all browsers. All are set to English. The weird thing about this is that it only effects Google and Yahoo which are the largest search engines.

#4 Tomk

Tomk

    Beguilement Monitor

  • Classroom Admin
  • 20,144 posts

Posted 10 February 2008 - 08:03 PM

Desert rider,
This may be a dumb question but, where are you located? Google uses the location of your ISP to determine what page you should start on. If you are in a country other than the United States and want to not be redirected, you need to set set your homepage to google.com/ncr which I believe stands for google no country reference.

Tomk
------------------------------------------------------------

mvplogo1_zpsea7gtc7e.gif


WTT-Grad1.jpg

Topics are closed after 5 days without response
unite_blue_zpsbfd3cd98.png


#5 Desert rider

Desert rider

    Authentic Member

  • Authentic Member
  • PipPip
  • 46 posts

Posted 10 February 2008 - 09:21 PM

Desert rider,
This may be a dumb question but, where are you located? Google uses the location of your ISP to determine what page you should start on. If you are in a country other than the United States and want to not be redirected, you need to set set your homepage to google.com/ncr which I believe stands for google no country reference.


Located in the US of A. ISP is also USA so I don't think that is the issue.

#6 Tomk

Tomk

    Beguilement Monitor

  • Classroom Admin
  • 20,144 posts

Posted 10 February 2008 - 09:38 PM

Located in the US of A. ISP is also USA so I don't think that is the issue.


Scratch one dumb question.

Beats my two pair :wacko:

Tomk
------------------------------------------------------------

mvplogo1_zpsea7gtc7e.gif


WTT-Grad1.jpg

Topics are closed after 5 days without response
unite_blue_zpsbfd3cd98.png


#7 Desert rider

Desert rider

    Authentic Member

  • Authentic Member
  • PipPip
  • 46 posts

Posted 11 February 2008 - 12:53 AM

The only dumb question is the one not asked. Thanks for taking the time to reply :thumbup:

#8 paws

paws

    Tech Team

  • Administrator
  • 5,934 posts

Posted 11 February 2008 - 07:37 AM

Hi Desert Rider It may be worth while you trying this: 1 From your Google page click on the link that says (to the right of the search bar) either favourites, or Einstellungen (its the middle one usually ,see your screen shot)) 2 From the next screen, select from the dropdown box English ( it might appear in the German spelling...but its' practically the same!) 3 From the list of languages select English, deselect German, (or anything else apart from English) 4 Save your preferences it may read as Einstellungen speichern 5 At the next screen click on OK See how you go Regards paws
The help you receive here is free. If you wish to show your appreciation, then you may donate to help keep us online. http://www.whatthetech.com/donate

#9 Desert rider

Desert rider

    Authentic Member

  • Authentic Member
  • PipPip
  • 46 posts

Posted 11 February 2008 - 10:40 AM

Hi Paws, Thanks for the reply. Looks like you're located pretty close to the Prime Meridian in the UK! Opened Google Deutschland and made the preferences (Einstellungen) change to English. Saved preferences and the German page opens in English (see screenshot 1). Unfortunately, the default Google.com page still has the link to Google Deutschland and there isn't any reference to "Favorites" next to the search bar (see screenshot 2). There has to be some sort of hook causing Google.com to open in German after clearing all cache and cookies. The properties for the link show that it is pointed at Google (screenshot 3) but somehow it will open Google Deutschland (after cleaning cache and cookies) or will open Google English with the Google Deutschland link after choosing Google in English from the German page. This one is making me nuts! :pullhair:

Attached Thumbnails

  • googlede_english.gif
  • google_english.gif
  • google_linkprop.gif

Edited by Desert rider, 11 February 2008 - 10:56 AM.


#10 Tomk

Tomk

    Beguilement Monitor

  • Classroom Admin
  • 20,144 posts

Posted 11 February 2008 - 11:01 AM

Desert rider, Just for grins try going to www.google.com/ncr and see if it cleans things up. When I tell google I want the german default, I get what you have. When I go to www.google.com/ncr it all clears up.

Tomk
------------------------------------------------------------

mvplogo1_zpsea7gtc7e.gif


WTT-Grad1.jpg

Topics are closed after 5 days without response
unite_blue_zpsbfd3cd98.png

    Advertisements

Register to Remove


#11 paws

paws

    Tech Team

  • Administrator
  • 5,934 posts

Posted 11 February 2008 - 12:22 PM

Hi Desert Rider

and there isn't any reference to "Favorites" next to the search bar (see screenshot 2).

Sorry , this was my bad translation......for Favourites please read Preferences
Try the instructions again ( in full) and see how you go.
Alternative strategy 1
Use System Restore and try to restore your system to a time a week or so before the trouble with Google started......its worth a try and if no joy is easily reversible.
Alternative strategy 2
Uninstall IE do a disc clean up, delete cookies and temps. reboot and reinstall IE and now allow cookies and see how you go........ditto for Firefox.
Regards
paws
Ps yes, on a clear day I can "see" the Greenwich meridan from my workshop window! :)
The help you receive here is free. If you wish to show your appreciation, then you may donate to help keep us online. http://www.whatthetech.com/donate

#12 Desert rider

Desert rider

    Authentic Member

  • Authentic Member
  • PipPip
  • 46 posts

Posted 11 February 2008 - 12:48 PM

Desert rider,
Just for grins try going to www.google.com/ncr and see if it cleans things up. When I tell google I want the german default, I get what you have. When I go to www.google.com/ncr it all clears up.


Alas, no grins.:wacko: Just tried that with no change. I'm going to do another CleanCache delete of all cache, cookies, history, etc. for all browsers, reboot and try again. I'll post if there is any change.

#13 Desert rider

Desert rider

    Authentic Member

  • Authentic Member
  • PipPip
  • 46 posts

Posted 11 February 2008 - 01:08 PM

Alternative strategy 1
Use System Restore and try to restore your system to a time a week or so before the trouble with Google started......its worth a try and if no joy is easily reversible.

Tried a couple of those with no success. Sort of a PITA to do each one going back a month or so with all the saves and reboots, etc. It might come to that though.

Alternative strategy 2
Uninstall IE do a disc clean up, delete cookies and temps. reboot and reinstall IE and now allow cookies and see how you go........ditto for Firefox.

Yeah, I thought of that but there are a LOT of prefs and addons for both browsers I would have to recreate and reinstall. Not sure if it would be worth it for this problem as it really hasn't effected my system performance and all scans with anti-virus, anti-malware, etc. are coming up clean with no sign of Trojans, spyware, keyloggers, etc.

Thanks for the replies and I'll post if any changes.

#14 kazzoo

kazzoo

    Authentic Member

  • Visiting Tech
  • PipPip
  • 224 posts

Posted 11 February 2008 - 02:24 PM

Greetings Desert Rider A quick thought, might you have a firewall/antimalware program keeping you from changing your home page? Regards Kaz.
Badgers? I dont need no stinking Badgers!

#15 Desert rider

Desert rider

    Authentic Member

  • Authentic Member
  • PipPip
  • 46 posts

Posted 11 February 2008 - 03:44 PM

Hi Kaz,

Thanks for the reply. The Google link thats causing all the problems is not my homepage. It's just a link on the browser link toolbars. I'm running Active Virus Shield from Kaspersky and Comodo Firewall Pro. I also have Tea Timer Resident (from Spybot S & D) but it is disabled right now due to runniing HJT and Combo-Fix. I just haven't restarted it yet.

Again, click here for a link to the topic on the other forum (Spyware / Malware / Virus Removal/HiJack This logs) that I originally posted on and worked with LD Tate to try and solve this. It has a complete history of what we did and all the logs. If you take a look you may pick up something we didn't.

Edited by Desert rider, 11 February 2008 - 04:44 PM.

Related Topics



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users