Jump to content

Build Theme!
  • Infected?

big grin Welcome to What the Tech's support forums!

We invite you to ask questions, share experiences, and learn. It's 100% free. Join 90484 others. Anybody can ask, anybody can answer. Consistently helpful members with best answers are invited to staff. Here's how it works. Computer cleanup? Start here> Malware Removal Forum.

Sign Up


write protected USB drive

  • Please log in to reply
2 replies to this topic

#1 paultpa


    Authentic Member

  • Authentic Member
  • PipPip
  • 193 posts

Posted 22 January 2012 - 05:22 AM

Morning, I have had a sudden popup lately saying the Verbatim device in my F: USB drive is "write protected," and it does not allow me to move or delete files. However, some .jpg files are also slowly disappearing, not of my doing. I suspected an infection and worked with Jintan in the Malware and Virus area of this forum. Great effort, no luck, so he suggested I address it here. Is there anything further you know of that we can try to remove the "write protected" stautus and deal with whatever is making the graphics files go to black? Many thanks.


Register to Remove

#2 Doug


    Retired Administrator -Tech Team

  • Tech Team
  • 10,057 posts

Posted 23 January 2012 - 08:48 PM

Hi Paultpa,

I read your previous Topic where you received help from the expert, Jintan, only up to the point of learning that you are running XP Professional SP3. had one or more infections, had difficulty with an older version of AVG antivirus, had Threatfire installed, and had several system warning conflicts related to AVG, Iomega products, and a few more conflicts.

It always helps when the Topic starter gives basic information about their machine, their operating system, any suspect software, the particular feature that is causing the identified problem (for instance the Brand and Model of USB stick causing the difficulty) and previous things you may have already tried to resolve the problem.

And most importantly, it would help to know if the saved information on that USB device is vulnerable.... meaning you do not want to loose the information and have not saved it anywhere else, and therefore must work to retrieve the information from the USB stick device without further risk of loose.

For instance, some "solutions" may involve procedures that would put your saved information at risk.
Such as Formating the device to restore its functionality, but at cost of loosing all the saved information on it.

I may necessarily go back and read your complete malware removal thread to better understand and gleen some clues regarding what may be going on, but for now, it could still help for you to provide some of the above basics to fill in our starting point.

For instance, some USB memory sticks have a physical switch which can be clicked to "lock" / "write protect" the device.
If yours is one of them, have you checked that feature?

Sometimes it is not the USB memory stick device itself, but rather the USB port into which it is plugged.
Have you tried the USB stick in other USB ports on this machine?
Have you tried the USB stick with another known-good machine?

Have you cleared the USB controllers and allowed them to be freshly installed?
--- how-to information here: http://support.microsoft.com/kb/817900

Is Threatfire still installed on that machine?
If so, it can be extremely agressive and prevent even some normal routine computer functions that might include your present problem.
If so, you might consider completely uninstalling Threatfire.

Have you worked in the machine's Registry to assure that no control set policy is causing USB devices to be "write protected"?

Have you created recent Restore Points and separately backed up your registry?
If none of the above mentioned basics apply in your situation, then we will probably be heading to the Registry to at least take a look and possibly to effect a solution.
But I would not want to venture into Registry work with you, unless you already have a competent Registry Backup, created by a good tool such as ERUNT.
Let me know if you have already backed up your Registry?

Have you attempted to access and copy/retrieve the files on that USB Stick via Command Prompt (the DOS-like utility) that would allow you to access Directories, folders and files outside of the usual Windows tools?

Have you attempted any repair/retrieval via SAFE Mode?

I realize I've asked a bunch of questions and hardly offered any suggestions, but I do need the requested information in order to offer the best informed suggestions for solution that you deserve.

Best Regards,

The help you receive here is free.
If you wish, you may Donate to help keep us online.

#3 paultpa


    Authentic Member

  • Authentic Member
  • PipPip
  • 193 posts

Posted 25 January 2012 - 03:38 PM

Doug, Appreciate your post and partnering on this. Jintan is a winner, terrific tech, but this is a tough problem. The problem again in a nutshell: a popup informs me a USB device (8GB Verbatim thumb/flash drive) is write protected and will not allow any deletions to it. It normally resides in my F: drive but I have moved it to different USB ports on occasion. The second issue is that graphics files are slowly going grey then black, so pics are disappearing, hence it suggested an infection. Yes, older Compaq laptop, XP Pro SP3. Other answers: - the info on the USB is vulnerable, it is where I save files on all daily work, correspondence, etc. Otherwise I do not save to hard drive. Some of the files are duplicated elsewhere, but it is the primary workhorse. - re-formatting the device is very risky and would result in too much loss. I would prefer to go to another USB device before doing that. - the Iomega external zip drive is rarely used at all anymore. - this Verbatim stick device does not have a sliding "lock" switch, as do newer ones. - the Verbatim has been moved/used in other USB ports on this Compaq. It performs as usual, but results in saving data to a new drive letter (e.g., to E: instead of F:) I have used it in a more recent IBM laptop but not used it in new HP laptop. The Compaq laptop is circa 2005, the IBM laptop circa 2006 (it was required by IBM) and the new HP is 2011. NOTE: I installed Magic Jack in Oct. 2011. It never did well. When I took that device and put it into the new HP laptop calls were crystal clear, as I remember them from pals at Cisco showing me VOIP calls back in 2001-2002 when they were starting unified messaging. It's the ports, USB1, USB2 . . . - I have not cleared and re-installed any USB controllers. - Threatfire was un-installed per Jintan's suggestion. - I have not done anything within registry to write protect the device. This activity is recent. - I MAY have backed up the regstry on an earlier visit here at the forum. Past posts with the good techs here may have a record of that. ERUNT sounds familiar but I cannot be sure. Otherwise I have not done anything like that on my own. Nor have I created any Restore Points, although that may have been done while following a process with a tech here. - Negative on the attempt to access files via Command Prompt. Only thru Windows and Safe Mode. Ask for anything you need to know, am here to cooperate and follow your lead. Many thanks. paultpa

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users