Jump to content

Build Theme!
  •  
  • Infected?

Welcome to What the Tech - Register now for FREE

A community of volunteers who share their knowledge, and answer your tech questions. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message, and all ads will be removed once you have signed in.

Create an Account Login to Account


Photo

Internet Explorer 9 - Opening Links


  • Please log in to reply
12 replies to this topic

#1 DtGoesWTT

DtGoesWTT

    New Member

  • Authentic Member
  • Pip
  • 14 posts

Posted 18 July 2011 - 01:46 AM

Hi there! I've tried searching for an answer but have failed, if there is a similar post or topic please let me know and i apologies for not being able to find it. But i've had this probelm for a while, when i click on particular links when using ie9 they refuse to open. Say, for example, i'm in my university account and i want to check my email, i click the email link and nothing happens. Even if i right click and say "open in new tab" it brings up a blank white page with the link in the address bar staying the same as the previous address visited. If i tried to open one of the topic's by scroll clicking a similar problem occurs, a blank white page with the previous address in the address bar. However, opening links from my favourites has not been a problem, i can scroll click or simply follow the link and it always opens. I had the same problem with ie8 and upgraded to ie9 hoping to fix it but nothings changed. I can't remember when this problem occured, but having to use a shared computer at home can only end up resulting in problems. Thank you for your time, its much appreciated!

Advertisement


#2 Ztruker

Ztruker

    WTT Tech

  • Tech Team
  • 7,056 posts
  • Interests:Helping people fix MS Windows related computer problems of all kinds.

    Good, inexpensive wine (not an oxymoron).

Posted 18 July 2011 - 08:27 AM

Try starting IE9 without any Add-ons. See if the problem still occurs.

Click on Start, All Programs, Accessories, System Tools, Internet Explorer (no Add-ons).

If the problem does not occur then you need to start IE9 normally and disable some Add-ons and test. Repeat until you find the Add-on that is causing the problem.

From IE9, click on Tools (the Gear icon, top right), Manage Add-ons.

#3 DtGoesWTT

DtGoesWTT

    New Member

  • Authentic Member
  • Pip
  • 14 posts

Posted 18 July 2011 - 06:21 PM

Thanks for your help with this problem, defintely appreicated! I did as you said, ran ie9 with add-ons disabled, and unfortunately the same problem occured, any other ideas?

#4 Ztruker

Ztruker

    WTT Tech

  • Tech Team
  • 7,056 posts
  • Interests:Helping people fix MS Windows related computer problems of all kinds.

    Good, inexpensive wine (not an oxymoron).

Posted 18 July 2011 - 08:11 PM

What anti-virus program are you using? What firewall are you using? As a test, and only for the time you are testing, try disabling one, then the other. See if that has any effect on the problem. Try Tools, Safety, Turn off Smart Screen Filter, see if that helps. Next, try Tools, Internet Options. Click on the General tab then under Browsing history, click the Delete button. Make sure Temporary Internet Files, Cookies and History boxes are checked then click the Delete button. See what that does for you. Create a new account for testing purposes. Call it whatever you want but it might be a good id3ea to name it something you can live with as you may end up keeping it if the problem does not occur with the new account. Post results please.

Edited by Ztruker, 18 July 2011 - 08:13 PM.


#5 DtGoesWTT

DtGoesWTT

    New Member

  • Authentic Member
  • Pip
  • 14 posts

Posted 18 July 2011 - 08:34 PM

I am using Avira AntiVir Personal - Free AntiVirus (something free that came with the computer) Only using the windows firewall that comes with the windows 7 Disabling either didn't make a difference to the problem. Tried to turn off smart screen filter, didn't help. Deleted Temporary internet files, Cookies and History, no change. Sorry but i don't understand what you mean by create a new account for testing purposes, can you please explain further? I noticed something when i was trying some of the things you recommending, when i initially tried to open the link, a red shield with a cross in the middle of it appeared at the end of the address bar to the left of the refreash and stop buttons at the end of the address bar, where you might find a icon indicating compatibility view. This red shield then turned into a lock that, when i held my mouse over it, indicated that it was a security report. The lock eventually disappears. I'm not sure what this all is but i hope it helps. Thanks for your help!

#6 Ztruker

Ztruker

    WTT Tech

  • Tech Team
  • 7,056 posts
  • Interests:Helping people fix MS Windows related computer problems of all kinds.

    Good, inexpensive wine (not an oxymoron).

Posted 19 July 2011 - 06:07 PM

To create a new account, open Control Panel, User Accounts. Click on Manage another account, then Create a new account. Once done, logoff your current account and login with the new account. Test and see how things are.

#7 DtGoesWTT

DtGoesWTT

    New Member

  • Authentic Member
  • Pip
  • 14 posts

Posted 19 July 2011 - 08:58 PM

Ar ok, i understand now. So did as you said, created a brand new account and tried to see how things were and it produced the exact same results. Also tried other accounts on the computer, guest account, standard account and another admin account and they all produced the same results. Anything else i could try? Thanks for your persistence in this matter!

Edited by DtGoesWTT, 19 July 2011 - 08:58 PM.


#8 Ztruker

Ztruker

    WTT Tech

  • Tech Team
  • 7,056 posts
  • Interests:Helping people fix MS Windows related computer problems of all kinds.

    Good, inexpensive wine (not an oxymoron).

Posted 20 July 2011 - 06:35 PM

You can delete the new account then. At least it shows the account you are using is not corrupted, that's a step in the right direction.

Try a different web browser as a test, to see if the same problem occurs there. I recommend FireFox. Install it and see how it works.

If it's okay then we know to focus on IE8/9 and not the overall operating system.

#9 DtGoesWTT

DtGoesWTT

    New Member

  • Authentic Member
  • Pip
  • 14 posts

Posted 20 July 2011 - 08:03 PM

Alrighty, new account deleted. Tried firefox and google chrome and both work fine in opening links, so i think we can just focus on internet explorer. I know its one of those "Why doesn't he just use a different web browser..." kind of scenario's, but its a problem that i'd like to fix and i guess i do prefer ie over the other options

Edited by DtGoesWTT, 20 July 2011 - 08:03 PM.


#10 Ztruker

Ztruker

    WTT Tech

  • Tech Team
  • 7,056 posts
  • Interests:Helping people fix MS Windows related computer problems of all kinds.

    Good, inexpensive wine (not an oxymoron).

Posted 21 July 2011 - 04:41 PM

I would want to fix it too.

Try this next: How to reset Internet Explorer settings

#11 DtGoesWTT

DtGoesWTT

    New Member

  • Authentic Member
  • Pip
  • 14 posts

Posted 22 July 2011 - 07:36 PM

Reset ie settings, no change. Worth me maybe contacting Microsoft?

#12 Ztruker

Ztruker

    WTT Tech

  • Tech Team
  • 7,056 posts
  • Interests:Helping people fix MS Windows related computer problems of all kinds.

    Good, inexpensive wine (not an oxymoron).

Posted 22 July 2011 - 08:35 PM

Try turning off Popup Blocker, see if that fixes it. If so then use the Settings button add specific sites to an approved list then enable Popup Blocker again.

#13 RMW

RMW

    New Member

  • New Member
  • Pip
  • 1 posts

Posted 11 July 2012 - 09:24 AM

I had the same symptoms in IE9 on Windows 7 SP1 x64, opening new tabs would yeld a plank page with a filled in address bar with a red security report icon. This seemed to be affecting only links which used javascript to open a new tab. I tried resetting settings, and running no extentions. Neither worked. I did fix this by uninstalling IE9 then re-installing. DO NOT TRY. Once IE9 was uninstalled their was no version of IE installed, also IE9 and Chrome installers failed (also in safe mode) Ran updates, IE8 security hotfix, this caused bluescreen. After permutation of: trying updates in safe mode, installing firefox, running installer as administrator, and lots of reboots IE9 installer worked. This did fix the issue, but given these difficulties, i would not recommend it. I hope that this information is useful.

Advertisement




Similar Topics: Internet Explorer 9 - Opening Links     x


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users